В Docker на Windows не работает TTY режим

08 Фев, 2017 10:23
вытаюсь выполнить команду
docker-compose exec apache /bin/bash
и получаю ошибку:

the input device is not a TTY. If you are using mintty, try prefixing the command with 'winpty'

что делать? без поддержки TTY очень неудобно!
Отредактировано 08 Фев, 2017 14:25
08 Фев, 2017 14:28
Есть довольно простое решение для bash.exe (можно скачать отдельно, но как правило он устанавливается вместе с Git)
Создаете ярлык на рабочем столе:
"C:\Program Files\Git\bin\bash.exe" –login -i

Запускаете и все должно работать.
Более подробно можно почитать в этой статье: https://getcarina.com/docs/troubleshooting/troubleshooting-cannot-enable-tty-mode-on-windows/
 
Зарегистрируйтесь или войдите чтобы оставить сообщение.